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TI Connect™  Software Overview

The TI Connect™ software is a communications and data management package that allows the
user to connect the calculator to the computer through the use of a variety of communications
cables.  TI Connect™ enables the user to create, edit, and transfer data, back up and restore the
contents of the calculator, update the operating system and applications, and capture the screen
of the calculator.

Initially the TI Connect™ software includes the TI DeviceExplorer, TI ScreenCapture, Backup,
Restore, TI DataEditor, TI DeviceInformation, and Explore My TI Data tools. Optional software
applications can be installed and accessed through TI Connect™.  Some of these optional
applications include CellSheet Converter, StudyCards Creator, NoteFolio Creator, TimeSpan
Creator, LearningCheck Creator, TI Package Explorer, and TI Interactive.  Most of these
packages are free downloads from Texas Instruments.  TI Interactive is for purchase only.

TI Connect™ can communicate to the calculator through the computer USB interface to the
calculator USB interface using a standard mini-A to mini-B USB cable.  Communication with
calculators that do not have a USB interface can be performed through the calculator’s serial
interface using either the SilverLink (USB Graph Link) cable or the older Graph Link serial
cables. 

TI Connect™ and optional software applications are available for download from:
http://education.ti.com/educationportal/sites/US/productCategory/us_computer_software.html

TI Connect™ Screen

The TI Connect™ screen contains six buttons and one interface window.  The four buttons
across the top are: Home, Content Tools, TI Online, and Updates.  The lower two buttons ae
Options and Help.  The standard Windows buttons of close and minimize are included at the
upper right of the window.  The center of the window contains the interface window.

TI Connect™ Home Screen

Initially the Home screen is presented.  Through this screen the TI DeviceExplorer, TI
ScreenCapture, Backup, Restore, TI DataEditor, TI DeviceInformation, and Explore My TI Data
tools features are accessed.

Figure 1 TI Connect Home screen.
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TI Connect™ Software Tools

The TI DeviceExplorer application enables the user to transfer device files between a TI
handheld device and a computer.

The TI ScreenCapture application enables the user to capture and manipulate TI handheld device
screens.
 
The Backup application enables the user to backup the files of TI handheld devices. 

The Restore application enables the user to restore files to backed-up TI handheld devices.

The TI DataEditor application enables the user to create and manipulate data variables. 

The TI DeviceInformation (TI DeviceInfo) application enables the user to find information about
connected TI handheld devices.

The Explore My TI Data  application will open Windows Explorer and enable the user to work
with device and group files.

TI Connect™ Connect Tools Screen

The Content Tools screen initially presents icons for the optional applications CellSheet
Converter, StudyCards Creator, NoteFolio Creator, TimeSpan Creator, LearningCheck Creator,
TI Package Explorer, and TI Interactive.  The yellow caution symbol will be displayed on each
icon where the application is not loaded or available.  When the applications are loaded the
yellow caution symbol will be removed, the icon will no longer be grayed out, and the icon will
access the application.  These optional packages will not be addressed in this document.

Content Tools Screen Tools

The TI CellSheet™ Converter  application enables the user to convert spreadsheets to/from
device spreadsheets and computer spreadsheets.

Figure 2 Connect Tools Screen.
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The TI StudyCards™ Creator  application enables the user to create electronic flash cards and
transfer them between your device and computer.

The TI NoteFolio™ Creator  application enables the user to create notes and transfer them
between your device and computer.

The TImeSpan™ Creator  application enables the user to create time lines and send them to a
TI-83 Plus, TI-83 Plus Silver Edition, TI-84 Plus, or TI-84 Plus Silver Edition device.

The TI LearningCheck™ Creator  application enables the user to create educational documents
and share them with connected devices.

The TI Package Explorer software  application enables the user to view package files and send
their contents to connected TI handheld devices.

The TI InterActive!™ software  application enables the user to create and use interactive math
and science documents.

Connecting the Calculator to the Computer

Two communications cables will be addressed.  The standard mini-A to mini-B USB cable,
preferred cable, and the SilverLink (USB Graph Link) cable.

Both cables have a standard USB on one end which connects to an available USB port on the
computer.  The drivers for the cables are part of the TI Connect™ software package and are
loaded onto the computer when the software is installed.

Connecting the mini-A to mini-B USB Cable

Insert the mini-A end of the mini-A to mini-B USB cable into a USB port on the computer. 
When you insert the mini-B end into the USB port on the calculator, the calculator will turn on
and when using Windows XP a Found New Hardware USB Device message may be displayed
on the computer.  This message will change to a Found New Hardware TI Educational Handheld
Device message.  A Found New Hardware Wizard window will appear.  This Found New
Hardware Wizard will only appear the first time a USB port is used on the PC.

Figure 3 Found New Hardware Wizard.
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The Install the software automatically (Recommended) will be selected, click Next.  The
message in the Found New Hardware Wizard will change to Please wait while the wizard
searches... message.  On Windows XP™ a warning message will be displayed, select Continue
Anyway.

The final message will be Completing the Found New Hardware Wizard message, select Finish.  

The final Found New Hardware Your new hardware is installed and ready to use message will be
displayed, close this message.  The computer is now ready to use the cable to communicate with
the calculator.

If a different USB port is used at another time, the Found New Hardware process will be
performed for that port.  When a USB port is used that had been previously used, the driver will
not be re loaded.

Figure 4 Hardware Installation Warning.

Figure 5 Hardware Wizard Completed.

Figure 6 Found New Hardware.
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Connecting the SilverLink (USB Graph Link) Cable

When the silver USB to calculator serial cable is inserted into a USB port on the computer, a
Found New Hardware TI-Graph Link USB message will be displayed on the computer.

This message will change to a Found New Hardware Texas Instruments SilverLink (USB Graph
Link) Cable message.

The final message will be Found New Hardware Your new hardware is installed and ready to
use.  The computer is now ready to use the cable to communicate with the calculator.

If a different USB port is used at another time, the Found New Hardware process will be
performed for that port.  When a USB port is used that hade been previously used, the driver will
not be re loaded.  Plug the other end of the SilverLink cable, 1/8 inch sterio phono plug, into the
round 1/8 inch jack on the calculator.  The calculator will turn on when the plug is connected to
the calculator.

Using the TI Connect™ Software Tools

The TI Connect™ software will attempt to connect to the calculator whenever a tool is selected. 
The com ports will be displayed and searched for a connection to a calculator.

If a SilverLink cable is used a USB 1 port will also be displayed regardless if the SilverLink
cable is connected to the calculator or not.  When using the USB mini-A to mini-B, the USB 1
port will only be displayed when the calculator is turned on.  The calculator must be turned on in

Figure 7 Found TI-Graph Link USB.

Figure 8 Found SilverLink Cable.

Figure 9 New Hardware Installed.

Figure 10 Searching for TI Device.
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order for the computer to locate and connect to the calculator.  If necessary, press the Select
button.

When connected, a software tool specific window will be displayed.  From each tool window,
the other software tools can be accessed through the icons or Tools or Actions menus.  The
software tool window can be accessed by selecting the Home button.

TI DeviceExplorer

TI Device Explorer enables the user to transfer device files between a TI handheld device and a
computer.  The window displays a tree structure of the information on the calculator.  Clicking
on the ~+ will expand the tree of the selected section.  For example, clicking on the  ~+ next to
Program will expand and display all of the programs on the calculator.  Clicking on the ~! will
collapse the tree of the selected section.  Items within a group can be copied to the PC or updated
from the PC through File menu or traditional Windows drag and drop techniques.  Items on the
calculator can also be deleted through the right click delete menu of the mouse.  Many items can
also be opened through the right click open menu of the mouse.  Programs can not be opened
through TI Connect™, they can be created and edited using the older TI-Graph Link software for
the specific calculator.

Figure 11 Searching for Device with a connected USB
Cable.

Figure 12 Device Explorer Window.
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TI ScreenCapture

TI Screen Capture enables the user to capture and manipulate the display of the calculator for use
in documents.  Prepare the calculator with the desired screen and select TI ScreenCapture.

Through the View menu, the Default Screen Size can be selected as 100%, 200%, or 300%.

An existing captured screen can be resized through the Image menu Resize option.  Also through
the Image menu, the image can be Flipped horizontally; Rotated 90E, 180E, or 270E; or add a
border to the image.  Once the image is saved, the boarder option is no longer available.  The
Image menu is only available when there is an image opened.  After saving the image as a
bitmap, .bmp, file the Windows Paint program can be launched from the Image menu through
Launch Image Editor and used to edit the image.  Save the image by selecting Save As from the
File menu.  Navigate to the desired directory, My TI Data is the default directory, supply a name
and select Save.  The default file type is BMP but can be changed to a variety of file types.

Additional screen captures can be performed by using the Get Screen selection in the Actions
menu.  The active image can be sent back to the calculator by using Send to Device from the
Actions menu.  The image will be sent and saved on the calculator as a picture.  A message
window will appear allowing the user to select a picture name, pic0 through pic9, and where in
memory to save it in the calculator, RAM or Archive.  Select the desired picture name and
accept the memory location RAM. To display the picture on the calculator select Draw, [2nd]
[PRGM], cursor over to STO and select RecallPic, [2].  RecallPic requires the name of the
picture which can be selected through [VARS] then Picture, [4], then scroll and select the
desired picture.

The stored bitmap images on the computer can be inserted into a document.  Open the word
processing program Microsoft Word.  TI ScreenCapture select the desired screen image and
select Copy from the Edit menu.  In Microsoft Word position the cursor to the desired insert

Figure 13 Screen Capture Window.
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location and select Paste from the Edit menu.  The same process can be done in Microsoft
PowerPoint and other programs.

Backup

Backup enables the user to backup the calculator’s RAM, memory, Archive, or Apps,
applications.  Archive will only be selectable if there is an Archive on the calculator, By default
RAM and Apps will be selected.  Select the desired components on the calculator that is desired
to backup.  The estimated backup size will be displayed.  Through the Backup to: field the
backup file name is specified.  The location and file name can be selected by selecting the Open
Folder icon to the right of the field.  Once a suitable backup location and file name has been
selected, the backup process is started by selecting the OK button.

Restore

Restore enables the user to restore the calculator to a previously saved backup condition.  
The initial Open dialog window allows the user to navigate to and select the backup file to
restore to the calculator.  Once selected, select the Open button.

The Restore window is now displayed.  The components that were backed up are available to
restore, RAM, Archive, and Apps, same as Backup.  Select the components that are desired to
restore on the calculator.  Select the OK button to begin the restore process.

Figure 14 Backup Window.

Figure 15 Restore Open Window.
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If there are items on the calculator that are going to be overwritten by the restore process, a
warning window will appear.  If all of the older values on the calculator are to be replaced, select
Replace All.  Otherwise, process each item with a Replace, Rename, or Skip.  The Restore
process can be terminated by selecting Cancel.

TI DataEditor

The Data Editor enables the user to create and edit numeric variables, lists, and matrices.

Through the File menu, a New Number, New List, or New Matrix can be created.  The numbers,
lists, and matrices can be closed, saved, or opened through the File menu.  The numbers, lists, or
matrices can be exported to or imported from Excel comma separated or text files.  The

Figure 16 Restore Window.

Figure 17 Replace Window.



©Pyzdrowski 2007
10

properties of the item can be adjusted by selecting Properties from the File menu or by right
clicking the item and selecting Properties from the pop up menu.  The Number Editor, List
Editor, or Matrix Editor can be made active through the View menu or by selecting the
appropriate button at the bottom of the window.  The numbers, lists, or matrices can be sent to
the calculator by right clicking the item and selecting Send or through a variety of send options
under the Actions menu.  Standard editing features of Cut, Copy, Paste, Select, Insert, and Delete
are available through the Edit menu.

Managing number variables

A Number variable contains a Name and a Value.  Several numbers variables can be created and
modified by selecting New Number from File menu.  Select a number variable and enter a value. 
Right click a number variable and select Properties.  Enter a single character name of the number
variable in the Variable Name field.  Select OK to accept the name.

Managing list variables

A List variable contains a Name and a list of values.  Several list variables can be created and
modified by selecting New List from File menu.  Select a cell of a list variable and enter a value. 
After pressing enter, the selection will move to the next cell for data entry.  Right click a list
variable and select Properties.  Enter a name for the list variable in the Variable Name field. 
Select OK to accept the name.  The default lists L1 Through L6 appear in the variable name area
with radio buttons beside each.  To use a default list, select the appropriate radio button.

Figure 19 Number Variable Properties Window.
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Managing matrix variables

A Matrix variable contains a Name and a matrix of values.  Only one matrix can be modified at a
time.   Select a cell of a list variable and enter a value.  After pressing enter, the selection will
move to the next cell down for data entry.  At the end of a column, the selection will move to the
first cell of the next column.  Right click a list variable and select Properties.  Only the single
character names A through J can be used for a matrix.  Select the name by checking the
associated radio button in the Variable Name area.  The number of rows and columns can be
adjusted by entering a value in the Row and Col fields.  Select OK to accept the changes.

Figure 20 List Variable Properties Window

Figure 21 Matrix Variable Properties Window.
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TI DeviceInformation (TI DeviceInfo)

Device Information retrieves information about the calculator.  Three areas of information are
provided: General Information, Installed Applications, and ID Lists.  The General Information
tab displays the type of calculator, the operating system version, BIOS version, amount of
memory, and other general information.  The Installed Applications tab displays a list of the
applications that are currently installed in the calculator.  The ID List tab repeats the Device ID
found on the General Information tab.

Explore My TI Data

Explore My TIData opens a Windows Explorer session of the PC’s default TI Connect™ data
directory.  The user can manage files and work with device and group files.

Figure 22 Device Information
Window.


